猫でもわかるWebプログラミング

試行錯誤しながらエンジニア(プログラマー)として働く猫のブログ。技術的な話や、働き方の話、読書録とか、試行錯誤している日常の話。

Mac

MacBook / MacBook Pro のUSBが足りないので、USB-C ハブ【レビュー】

何を買ったのか MacBook のポートが足りない このUSB-Cハブについて ついているポートについて 安い ただし安っぽい 何を買ったのか MacBook や MacBook Pro 用に USB-C ハブを買ってしばらく使ったので、そのレビューを書きます。 買ったのはこちらです。 U…

今 Mac を買うなら MacBook Air を買いたい

Apple の価格シミュレーションをするのが大好き 僕はいつも Mac のノートパソコンを使っています。そして、新しい Mac が発売されると心躍らせて購入ページに行き、価格シミュレーションをします。実際には買わないのですが。*1 Apple は 2019年の11月14日に…

Macに接続したiPhoneの通信内容をWiresharkで見る

はじめに 以下のサイトを参考にしました 環境 手順 Wiresharkのインストール Remote Virtual Interface の設定 iPhoneのUDIDの確認 Remote Virtual Interface の設定 Wireshark で確認 参考 はじめに Wireshark には最大の欠点があります。「通信の中身は基…

Mac Homebrew で Error: Cask XXXX exists in multiple taps: と言われた場合

結論 brew untap <name> で該当リポジトリをuntapすれば良い。 エラー tfenv をインストールした時に Homebrew のアップデートが始まり以下のエラーが出た。 $ brew install tfenv Updating Homebrew... ==> `brew cleanup` has not been run in 30 days, running </name>…

Macにnpmをインストールする方法 in 令和(2019年)

僕が考える最強の「Macにnpmをインストールする方法」in 2019 環境 nodebrew nodebrewでnodeを入れる npmを入れる 環境 macOS Mojave Homebrewはインストール済みである前提 nodebrew npmを動かすためにはnodeを入れなければ入れないのだが、簡単にnodeのバ…

macOS Mojave / High Sierra に VirtualBox をインストールしようとして「インストールできませんでした」

環境 解決方法 参考 macOS Mojave に VirtualBoxをインストールしようとしたところ「インストールできませんでした」と出てきてしまったので、解決方法です。 インストールできませんでした 環境 macOS Mojave High Sierra でも起こるようです *1 VirtualBox…

MacBook Proがなんか重い、異様にファンが回る時などの対応メモ

Mac

はじめに 容量を見る dockerのいらんやつ消す vagrantのboxを消す SMCリセット はじめに MacBook Proを使って4年くらい、動作がかなりもっさりしてきて、何もしてないのにファンが高速回転するような状況に。買いかえても良いんだけど、新しいMacにするとThu…

Warning (el-get): Your Emacs doesn't support HTTPS (TLS). と言われた時の対処 for Mac - HTTPS (TLS) 対応版のEmacsをインストールしたい

いきさつ el-getを使っていると以下のようなWarningが出ることがある。 Warning (el-get): Your Emacs doesn't support HTTPS (TLS). まあWarningなので無視しても問題ないっちゃ問題ないのだが、いちいち出てくるのがうざい。EmacsをTLSに対応させることで…

brew upgrade したら Emacs がターミナル上じゃなくてGUIで起動するようになったのでターミナルで起動するように戻したい

いきさつ brew upgrade したら Emacs のバージョンが25になり、ターミナル上ではなくGUIで起動するようになった。GUIで起動しても大きな不便はないだろうと思っていたのだが、以下の問題があった。 Google日本語入力IMEが働かない(日本語が入力できない) g…

MacでHomebrewを使っていて、コマンドラインから叩くphpのバージョンがなんかおかしくなった場合の対処

概要 ある日 composer install するとこんな警告が出た phpunit/phpunit 5.7.21 requires php ^5.6 || ^7.0 -> your PHP version (5.5.20) does not satisfy that requirement. phpunit 5.7.21 を利用するには php5.6 以上または php7.0 以上が必要だが、あ…